Website Hosting Outage Update
Incident Report for Digistorm
Resolved
Connection to all Digistorm Education websites is stable since being restored. Thank you for your patience while we have worked through this.

Please contact Digistorm Education on 07 5508 2929 or support@digistorm.com.au if you would like any further details.
Posted over 3 years ago. Jun 07, 2016 - 16:03 AEST
Monitoring
We believe that we have rectified the issues affecting selected websites and are monitoring the system closely.
Posted over 3 years ago. Jun 07, 2016 - 15:38 AEST