Website Outage Identified
Incident Report for Digistorm
Resolved
Connection to all Digistorm websites is stable since being restored. Thank you for your patience while we have worked through this.
Posted over 2 years ago. Jul 13, 2017 - 17:03 AEST
Identified
We have identified the cause of the website outage and our engineers our working to have all websites back online as soon as possible. We will provide an update as soon as we have restored network functionality.
Posted over 2 years ago. Jul 13, 2017 - 15:48 AEST