Website Outage Investigations
Incident Report for Digistorm
Resolved
Connection to all Digistorm Education websites is stable since being restored. Thank you for your patience while we have worked through this.

Please contact Digistorm Education on 07 5508 2929 or support@digistorm.com.au if you would like any further details.
Posted almost 3 years ago. Oct 19, 2016 - 15:21 AEST
Investigating
We are aware of service interruptions affecting some of our websites are currently investigating this issue. We will provide an update as soon as we have identified the issue.
Posted almost 3 years ago. Oct 19, 2016 - 15:15 AEST